Smarty Forum Index Smarty
The discussions here are for Smarty, a template engine for the PHP programming language.
Smarty 3.1.17 from Composer

 
Post new topic   Reply to topic    Smarty Forum Index -> Installation and Setup
View previous topic :: View next topic  
Author Message
habatur
Smarty n00b


Joined: 15 Mar 2014
Posts: 3

PostPosted: Sat Mar 15, 2014 3:40 am    Post subject: Smarty 3.1.17 from Composer Reply with quote

I have installed in two projects, through composer, the Smarty 3.1.17 version.

In project 1, all works fine.
In project 2 however, I get an error,
Quote:
The file Smarty_Internal_TemplateCompilerBase.php is missing in the libs folder.


I have temporarily fixed that by adding these lines in the class:
Code:
include_once SMARTY_SYSPLUGINS_DIR.'smarty_internal_templatecompilerbase.php';
include_once SMARTY_SYSPLUGINS_DIR.'smarty_internal_templatelexer.php';
include_once SMARTY_SYSPLUGINS_DIR.'smarty_internal_templateparser.php';
include_once SMARTY_SYSPLUGINS_DIR.'smarty_internal_compilebase.php';
include_once SMARTY_SYSPLUGINS_DIR.'smarty_internal_write_file.php';


However, is there a permissions or a php setting that I may be missing here so I can fix it by the time 3.1.18 comes aroud? What is strange is that it works just fine in another project. So I figured composer cant be the cause, default permissions cant be it either. It is very strange.
Back to top
View user's profile Send private message
mohrt
Administrator


Joined: 16 Apr 2003
Posts: 7285
Location: Lincoln Nebraska, USA

PostPosted: Sun Mar 16, 2014 1:33 am    Post subject: Reply with quote

Is this a project you updated Smarty? Be sure to clear out all cached and compiled files.
Back to top
View user's profile Send private message Visit poster's website
habatur
Smarty n00b


Joined: 15 Mar 2014
Posts: 3

PostPosted: Mon Mar 17, 2014 12:13 am    Post subject: Reply with quote

mohrt wrote:
Is this a project you updated Smarty? Be sure to clear out all cached and compiled files.


No, the project that was updated works fine.
The new smarty install wasn't loading a few files in what I suppose is a Smarty autoloader, which means there could be a potential conflict. It is not a bug though, only an issue that will occur on each update until the cause is figured out.

The project I loaded it in was php-login.net's MVC version
Back to top
View user's profile Send private message
habatur
Smarty n00b


Joined: 15 Mar 2014
Posts: 3

PostPosted: Wed Sep 17, 2014 3:03 pm    Post subject: Reply with quote

The problem still occurs in version 3.1.19 in a clean install.
It is simply not compatible with composer I guess.
Back to top
View user's profile Send private message
U.Tews
Administrator


Joined: 22 Nov 2006
Posts: 4672
Location: Hamburg / Germany

PostPosted: Sat Oct 18, 2014 1:15 am    Post subject: Reply with quote

Composer is now up running again. It does load the distribution currently from github.com/uwetews/smarty-dist. (This will change some time in the future)

On github v3.1.21 is alread tagged. The SVN gets updated tomorrow.

Use
"require": {
"smarty/smarty": "~3.1"
}
to get it.

You must run composer clearcache to get it working.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Smarty Forum Index -> Installation and Setup All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP