Smarty Forum Index Smarty
The discussions here are for Smarty, a template engine for the PHP programming language.

{strip} tag - not working...

 
Post new topic   Reply to topic    Smarty Forum Index -> General
View previous topic :: View next topic  
Author Message
lean4huskytop
Smarty Regular


Joined: 19 Aug 2003
Posts: 41

PostPosted: Fri Jan 16, 2004 5:35 am    Post subject: {strip} tag - not working... Reply with quote

My strip tag works fine on my home computer running my site but when I upload the site to the server on live computer the strip tag is not longer working...

how is that possible???? I have the latest version of Smarty...has it been depracated???
Back to top
View user's profile Send private message
andre
Smarty Pro


Joined: 23 Apr 2003
Posts: 164
Location: Karlsruhe, Germany

PostPosted: Fri Jan 16, 2004 7:45 am    Post subject: Reply with quote

Make sure you clear the templates_c and cache directory on your live computer. The {strip} plugin has changed sometimes in the last few versions of Smarty.
Back to top
View user's profile Send private message
lean4huskytop
Smarty Regular


Joined: 19 Aug 2003
Posts: 41

PostPosted: Fri Jan 16, 2004 8:03 am    Post subject: hey Reply with quote

I did what you asked me to and it didnt do anything. The strip tag is still not working.

I have the newest Smarty template version on my live computer.
At home I have older edition of Smarty....

Did the new one get rid of the strip template?

Again - at home its working fine.
Back to top
View user's profile Send private message
messju
Administrator


Joined: 16 Apr 2003
Posts: 3336
Location: Oldenburg, Germany

PostPosted: Fri Jan 16, 2004 8:13 am    Post subject: Reply with quote

we can't help you with a description like "it's not working".

do you get error-message? if so paste them here.
what do you expect? what do you get?
which precise versions do you use on you two different environments?
maybe it's also useful if you paste some code that doesn't get stripped.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
lean4huskytop
Smarty Regular


Joined: 19 Aug 2003
Posts: 41

PostPosted: Fri Jan 16, 2004 4:07 pm    Post subject: hey Reply with quote

My statement that "its not working" is correct. My HTML is not stripped on the live computer. My HTML is stripped on the home computer. All with the same code. Smarty version on the Live computer is one revision newer.

There are no errors, but the HTML is as though nothing else was added.

Please help Smile
Back to top
View user's profile Send private message
lean4huskytop
Smarty Regular


Joined: 19 Aug 2003
Posts: 41

PostPosted: Fri Jan 16, 2004 4:15 pm    Post subject: here is the code Reply with quote

here is the template code..maybe that will help:

Code:

{config_load file=index.conf section="setup"}
{strip}
{include file="index_header.tpl"}
{if $pageIdentity eq "index"}
<table cellSpacing="0" cellPadding="0" width="760" border="0" ID="Table3">
   <tbody>
      <tr>
         <td vAlign="top" width="500">
            <table cellSpacing="0" cellPadding="0" width="500" border="0" ID="Table4">
               <tbody>
                  <tr>
                     <td width="499" height="167">{*include file="index_featuredTrainer.tpl"*}
                     <TABLE height="167" cellSpacing="0" cellPadding="0" width="500" border="0" ID="Table5">
                        <TR>
                           <TD width="499" bgColor="white"><IMG src="{#mainPic#}">
                           </TD>
                        </TR>
                        <TR>
                           <TD width="499" bgColor="#ffffff"><IMG height="1" alt="" src="images/clearpix_002.gif" width="499">
                           </TD>
                        </TR>
                     </TABLE>
                     </td>
                  </tr>
               </tbody>
            </table>
         </td>
         <td vAlign="top" width="260" rowSpan="2">
            <table height="267" cellSpacing="0" cellPadding="0" width="260" border="0" ID="Table6">
               <tbody>
                  <tr bgColor="#e7e8ea">
                     <td style="HEIGHT: 23px" width="259">
                        {include file="index_trainerSearch.tpl"}
                     </td>
                     <td style="HEIGHT: 23px" width="1" bgColor="#9a9a9a">
                        <IMG src="images/clearpix_002.gif">
                     </td>
                  </tr>
                  <tr bgColor="#e7e8ea">
                     <td align="center" width="259">
                     </td>
                     <td width="1" bgColor="#9a9a9a"><IMG src="images/clearpix_002.gif">
                     </td>
                  </tr>
                  <tr bgColor="#e7e8ea">
                     <td align="center" width="259">
                     </td>
                     <td width="1" bgColor="#9a9a9a"><IMG src="images/clearpix_002.gif">
                     </td>
                  </tr>
                  <tr>
                     <td bgColor="#9a9a9a" colSpan="6" height="1"><IMG src="images/clearpix_002.gif">
                     </td>
                  </tr>
               </tbody>
            </table>
            <table height="249" cellSpacing="0" cellPadding="0" width="260" bgColor="#dadad9" border="0" ID="Table8">
               <tbody>
                  <tr>
                     <td vAlign="top" colSpan="5">
                        {include file="index_bottomThree.tpl"}
                     </td>
                     <td width="1" bgColor="#9a9a9a">
                        <IMG src="images/clearpix_002.gif">
                     </td>
                  </tr>
                  <tr>
                     <td bgColor="#9a9a9a" colSpan="6" height="1"><IMG src="images/clearpix_002.gif">
                     </td>
                  </tr>
               </tbody>
            </table>
         </td>
      </tr>
      <tr>
         <td vAlign="top" width="500" bgColor="#ffffff">
            <table id="Table19" height="330" cellSpacing="0" cellPadding="0" width="500" border="0">
               <tbody>
                  <tr height="22">
                     <td class="white11ab" width="498" bgColor="#000000">
                        &&&{$smarty.now|date_format:"%B %d, %Y"}
                     </td>
                     <td width="1" bgColor="#a0a07c"><IMG height="22" alt="" src="images/clearpix_002.gif" width="1">
                     </td>
                  </tr>
                  <tr>
                     <td vAlign="top">
                        <table id="Table20" cellSpacing="0" cellPadding="0" width="498" border="0">
                           <tbody>
                              <tr>
                                 <td align="center" colspan="2" background="images/bg_module_shadow.gif" height="14">
                                 </td>
                              </tr>
                              <tr>
                                 <td>
                                    {include file="index_trainerList.tpl"}
                                 </td>
                              </tr>
                           </tbody>
                        </table>
                     </td>
                     <td width="1" bgColor="#999998" rowSpan="3"><IMG height="176" alt="" src="images/clearpix_002.gif" width="1">
                     </td>
                  </tr>
               </tbody>
            </table>
         </td>
      </tr>
   </tbody>
</table>
{/if}
{include file="footer.tpl"}
{/strip}


thanks guys
Back to top
View user's profile Send private message
messju
Administrator


Joined: 16 Apr 2003
Posts: 3336
Location: Oldenburg, Germany

PostPosted: Fri Jan 16, 2004 5:25 pm    Post subject: Reply with quote

you still refuse to tell us which version is working for you and which not.
Back to top
View user's profile Send private message Send e-mail Visit poster's website
lean4huskytop
Smarty Regular


Joined: 19 Aug 2003
Posts: 41

PostPosted: Fri Jan 16, 2004 10:54 pm    Post subject: hi Reply with quote

Smarty version on the Live computer is the most current one. The one at home is one revision earlier.

Paul
Back to top
View user's profile Send private message
lean4huskytop
Smarty Regular


Joined: 19 Aug 2003
Posts: 41

PostPosted: Sat Jan 17, 2004 8:19 am    Post subject: hey Reply with quote

guys - I have fixed it. I had an old old old version on my website live...

thanks for your attention though...Smile

Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Smarty Forum Index -> General All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group
Protected by Anti-Spam ACP